Fixing the Sub at GodFirst Bryanston

Hey guys and girls…

Today I had the privilege of taking apart the sub from the HK LUCAS Max System in use at G1 Bryanston to figure out why the satellite speakers are working but the sub isn’t (FYI the amp for the satellites is built into the sub).

This is not the first time it has stopped working so I had a pretty good clue what the problem was… Anyway, lets have a look!

To open up the sub, at least the part I want to get to, you have to un-screw the 2 screws keeping the grill on the front:

Once that is off, you can now get a look at the 15″ 1.2kW Low Frequency Driver. I love the way that it looks so humble, especially compare to say a car audio subwoofer:

The sub is held in by 8 hex (allen) screws, that fortunately come out nice and quick with the Skil-Driver… just a side note here, a cordless screwdriver/drill is one of the best tools I’ve ever bought!

Once the sub was out I quickly noticed that the problem was the same as last time, as suspected, a broken lead wire:

This has broken before, so I hope that this repair will last longer, as I think it was less than a year ago that Mike Davis (Head of Sound at G1 Fourways) fixed it. Broke out the soldering iron and got to it, unfortunately I don’t have three arms so i couldn’t get a shot of me doing the soldering, anyway here is the fixed lead wire:

I need to remember to bring in my digital camera when I’m doing this, as my phone does not take great pictures! After the soldering I re-connected the speaker cable on the inside of the box and screwed everything back in!

While I had the sub in the office, I thought I would try to sort out the other problem that this system has had for probably 2 years. The input connector, which by the way is a Neutrik (Expensive connector!?) was damaged when the sub was loaded into my car for a worship/sound training day and after that when you plugged a cable into it, you couldn’t un-plug the cable! Here is what it looked like:

and then with the back panel removed:

As you can see the cable has taken a beating, being permanently plugged into the bottom of the sub which is on wheels. I had used duct tape to keep the cable ‘neatly’ in place, and when I removed it today, I had an epiphany! NEVER use duct tape on something for more than a week or so! It was gross!

I had to basically force the cable out, breaking the connector partially… aftermath here:

Anyway, I’ve cleaned it all up, and replaced the cable with a short one, that is permanently tied to the input cable that runs from the snake (A male – male XLR)

Hopefully this will last a while!!

Next major task at G1 Bryanston will be sorting out the mixing console and rack, that is completely empty, coz I ‘borrowed’ all the gear from it for a G1 City event, and the last Urban Force Event with Mark Driscoll at the Indaba Hotel. (There are some pictures floating around on FB of this event, but i can’t log in at the moment… weird!? anyway!) Will also be working on my first YouTube Video… once I come up with a good idea for my first one!

Advertisements

2 thoughts on “Fixing the Sub at GodFirst Bryanston

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s